Project

General

Profile

Actions

Defect #35038

closed

Error message when limited user want to add time entry and change assignee for a private issue

Added by Kam Nazir almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Time tracking
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

If a user(not admin) is assignee of a private issue, when he change it's assignee and add time_entry (at he same time) so that he can not access the issue after, redmine throws these error messages:
  • Log time is invalid
  • Issue is invalid

This scenario also happens when the user's role is limited to see only own issues.

I write a patch to fix it.


Files

fix_invalid_time_entry.patch (834 Bytes) fix_invalid_time_entry.patch fix invalid time_entry Kam Nazir, 2021-04-05 16:08

Related issues

Is duplicate of Redmine - Defect #34856: Time entry error on private issueClosedMarius BÄ‚LTEANU

Actions
Actions #1

Updated by Go MAEDA almost 3 years ago

  • Is duplicate of Defect #34856: Time entry error on private issue added
Actions #2

Updated by Go MAEDA almost 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Thank you for reporting the issue but I am closing this issue as a duplicate of #34856.

Actions

Also available in: Atom PDF