Defect #35225

Edit issue shows date in MM/DD/YYYY while the rest of the application shows YYYY/MM/DD

Added by Sergio Serrano 3 months ago. Updated 3 months ago.

Status:ResolvedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution: Affected version:4.1.2

Description

Dear redmine community

Issue list DD-MM-YYYY

Issue detail DD-MM-YYYY

Issue edit MM-DD-YYYY

Issue list and Issue details follows redmine date configuration but issue edit always use the MM-DD-YYYY format.

Please, any advice what I'm doing wrong?

Screenshot from 2021-05-11 08-35-03.png (18.3 KB) Sergio Serrano, 2021-05-11 08:35

Screenshot from 2021-05-11 08-36-48.png (21.2 KB) Sergio Serrano, 2021-05-11 08:37

Screenshot from 2021-05-11 08-39-12.png (37 KB) Sergio Serrano, 2021-05-11 08:39


Related issues

Related to Redmine - Feature #31300: Automatically switch between native date picker and custo... New

History

#1 Updated by Sergio Serrano 3 months ago

Issue list DD-MM-YYYY (creation date)

Issue detail DD-MM-YYYY (start and due date)

Issue edit MM-DD-YYYY (start and due date)

Thank you for your feedback

#2 Updated by Holger Just 3 months ago

  • Related to Feature #31300: Automatically switch between native date picker and custom date picker based on mobile or not mobile devices added

#3 Updated by Holger Just 3 months ago

  • Status changed from New to Resolved

The edit forms (e.g. the issue edit form) use your browser's built-in interface for date entry. As such, the edit field will show the date using your browser's configured locale. The exact interface of the date picker, its configurability and locale entirely depends on your webbrowser.

As such, I believe this is not a bug in Redmine.

Also available in: Atom PDF