Defect #37441

No monospace (fixed length) font in markdown any longer

Added by A Fora 3 months ago. Updated about 12 hours ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Text formatting
Target version:-
Resolution:Invalid Affected version:4.2.7

Description

Monospace fonts used to work fine prior to upgrading to v.4.2.3 (I'm not sure which last version it worked fine).

However now, monospace fonts are gone in both code blocks and inline code deliniated with ``.

Example, the following entry in the markdown configured wiki:
text.png

is rendered with variable length fonts:
rendering.png

rendering.png (6.96 KB) A Fora, 2022-07-15 00:42

text.png (7.17 KB) A Fora, 2022-07-15 00:42

inlinecode-monospace.png (223 KB) Go MAEDA, 2022-07-15 01:56

History

#1 Updated by Go MAEDA 3 months ago

I cannot reproduce the issue. See inlinecode-monospace.png.

Do you use a third-party theme? Can you check if the monospace font is used when using Redmine's default theme?

#2 Updated by A Fora 3 months ago

I found the culprit - java script was for some reason disabled on that browser. Is this expected? To have markdown partially disabled without javascript?

#3 Updated by Marius BALTEANU about 12 hours ago

  • Status changed from New to Closed
  • Resolution set to Invalid

You should check your browser, Redmine doesn't have such kind of "feature" to disable the javascript partially.

Also available in: Atom PDF