Project

General

Profile

Actions

Patch #37525

closed

Update Pg to 1.5

Added by Go MAEDA over 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Gems support
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:


Related issues

Has duplicate Redmine - Defect #39137: redmine with ruby 3.0 and up cannot be installed due to unsupported pg-1.2.3. Need to upgrade to at least pg-1.3.xClosed

Actions
Actions #1

Updated by Yuichi HARADA over 1 year ago

I tested on PostgreSQL 10.21 with the following patch. There were no related test failures with Pg gem.

diff --git a/Gemfile b/Gemfile
index 37fe583757..61c359a445 100644
--- a/Gemfile
+++ b/Gemfile
@@ -67,7 +67,7 @@ if File.exist?(database_file)
       when 'mysql2'
         gem "mysql2", "~> 0.5.0", :platforms => [:mri, :mingw, :x64_mingw]
       when /postgresql/
-        gem "pg", "~> 1.2.2", :platforms => [:mri, :mingw, :x64_mingw]
+        gem "pg", "~> 1.4.2", :platforms => [:mri, :mingw, :x64_mingw]
       when /sqlite3/
         gem "sqlite3", "~> 1.4.0", :platforms => [:mri, :mingw, :x64_mingw]
       when /sqlserver/
Actions #2

Updated by Go MAEDA over 1 year ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the patch. Thank you.

Actions #3

Updated by Go MAEDA 8 months ago

  • Subject changed from Update Pg to 1.4 to Update Pg to 1.5

Update Pg to 1.5 in r22268.

Actions #4

Updated by Holger Just 5 months ago

  • Has duplicate Defect #39137: redmine with ruby 3.0 and up cannot be installed due to unsupported pg-1.2.3. Need to upgrade to at least pg-1.3.x added
Actions

Also available in: Atom PDF