Project

General

Profile

Actions

Feature #39761

closed

Ruby 3.3 support

Added by Go MAEDA 3 months ago. Updated about 1 month ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Ruby support
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed

Description

Ruby 3.3.0 is going to be released on December 25th, 2023.


Related issues

Copied from Redmine - Feature #38099: Add Ruby 3.2 supportClosedGo MAEDA

Actions
Actions #1

Updated by Go MAEDA 3 months ago

Actions #2

Updated by Go MAEDA 3 months ago

With Ruby 3.3.0-preview3, one test fails.

Failure:
Redmine::WikiFormatting::CommonMark::SanitizationFilterTest#test_should_sanitize_html_strings [/path/to/redmine/test/unit/lib/redmine/wiki_formatting/common_mark/sanitization_filter_test.rb:125]:
--- expected
+++ actual
@@ -1 +1 @@
-"<b>Lorem</b> <a title=\"foo\">ipsum</a> <a href=\"http://foo.com/\"><strong>dolor</strong></a> sit<br>amet &lt;script&gt;alert(\"hello world\");" 
+"<b>Lorem</b> <a title=\"foo\">ipsum</a> <a href=\"http://foo.com/\"><strong>dolor</strong></a> sit<br>amet script&gt;alert(\"hello world\");" 

bin/rails test test/unit/lib/redmine/wiki_formatting/common_mark/sanitization_filter_test.rb:123
Actions #3

Updated by Go MAEDA 2 months ago

  • Assignee deleted (Go MAEDA)
Actions #4

Updated by Mizuki ISHIKAWA about 1 month ago

Go MAEDA wrote in #note-2:

With Ruby 3.3.0-preview3, one test fails.

[...]

All tests were successful in my environment. I cannot reproduce the same problem as yours.

Actions #5

Updated by Go MAEDA about 1 month ago

Mizuki ISHIKAWA wrote in #note-4:

Go MAEDA wrote in #note-2:

With Ruby 3.3.0-preview3, one test fails.

[...]

All tests were successful in my environment. I cannot reproduce the same problem as yours.

Thank you, I confirmed that updating to Nokogiri 1.6.0 in r22576 fixed this issue.

Actions #6

Updated by Go MAEDA about 1 month ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Ruby 3.3 is now supported in r22609 and later.

Actions

Also available in: Atom PDF