Project

General

Profile

Actions

Feature #4602

open

User specific theme

Added by Jiří Křivánek about 14 years ago. Updated over 3 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
UI
Target version:
-
Start date:
2010-01-18
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

Hello,

I am sorry for bothering you again, this time (I know) with the stupid request.

I am just arguing with a few of my colleagues which theme is the best one. Well, we were not to find the same opinion to this matter.

Would it be possible to have the theme setting at the user account, say if blank then the system wide theme applies, otherwise, the user specific is used?

Thank you & best regards,

Jiri.


Related issues

Related to Redmine - Feature #13035: Add custom template zones that can be used in themesClosed

Actions
Related to Redmine - Feature #5987: Enable a custom theme to very clearly indicate on every page that you're logged in as an Admin userNew2010-07-29

Actions
Has duplicate Redmine - Feature #5579: Theme settings should be per-user not per-installClosed2010-05-24

Actions
Has duplicate Redmine - Feature #5993: Allow each user to select themeClosed2010-07-29

Actions
Has duplicate Redmine - Feature #16251: Theme changerClosed

Actions
Actions #1

Updated by diafza diafza almost 14 years ago

any luck with this?

Actions #2

Updated by Jiří Křivánek almost 14 years ago

No reaction from the Redmine development team at all...

Actions #3

Updated by Just Lest almost 14 years ago

+1

Actions #4

Updated by Tide _ almost 14 years ago

+1

Actions #5

Updated by minkbear minkbear almost 14 years ago

+1

Actions #6

Updated by Yuki Kita almost 14 years ago

+1

Actions #7

Updated by Gauthier Brion over 13 years ago

+1

Actions #8

Updated by Luke Dixon about 13 years ago

+1

Actions #10

Updated by Gauthier Brion about 13 years ago

For those falling on this issue, you can simply add this plugin :
http://www.redmine.org/plugins/themechanger

Actions #11

Updated by Jiří Křivánek almost 12 years ago

  • Status changed from New to Resolved
Actions #12

Updated by Jan Niggemann (redmine.org team member) about 11 years ago

  • Status changed from Resolved to New

IMHO this should be in trunk...

Actions #13

Updated by armin walland about 11 years ago

+1

Actions #14

Updated by Filou Centrinov about 11 years ago

Related to #5987, #13035
Duplicate: #5993

Actions #15

Updated by Toshi MARUYAMA about 11 years ago

Filou Centrinov wrote:

Related to #5987, #13035
Duplicate: #5993

Done.

Actions #16

Updated by Dipan Mehta almost 11 years ago

+1. This is a nice thing to have.

Actions #17

Updated by Stéphane Diemer almost 11 years ago

I have created a JavaScript theme loader to do this.
https://github.com/sdiemer/redmine-multi-theme

The theme selected by the user is stored in his cookies.
At each page loading, the theme loader get the value stored in cookies and add the required CSS file.

The themes in the list have been created automatically with a script I wrote.

PS: I didn't test it on IE, because I hate IE and no one in my company uses it, but it should work too.

Actions #18

Updated by Danil Tashkinov over 10 years ago

Yet another plugin for user specific theme: https://github.com/Undev/redmine_user_specific_theme

Actions #19

Updated by Jiří Křivánek over 10 years ago

  • Status changed from New to Resolved
  • For me the issue is resolved.
Actions #20

Updated by Jong-Ha Ahn about 10 years ago

+1

Actions #21

Updated by Viktor Berke about 10 years ago

+1 we don't want plugins for this, this functionality is really basic.

Actions #22

Updated by Jan Niggemann (redmine.org team member) about 10 years ago

  • Status changed from Resolved to Closed
Actions #23

Updated by Jan Niggemann (redmine.org team member) about 10 years ago

  • Status changed from Closed to New

Re-opening, closed the wrong issue...

Actions #24

Updated by Moisés Bites almost 9 years ago

I agree with Victor Berke that "we don't want plugins for this, this functionality is really basic".

This feature would be extremely useful. In our company, we have several different large areas using the same Redmine server, and many users have different preferences for viewing the demands.

Are there any plans this functionality get into some version of Redmine?

Actions #25

Updated by Anh Le Giang about 8 years ago

+ 1 for this. Really basic feature.

Actions #26

Updated by Toshi MARUYAMA about 8 years ago

  • Description updated (diff)
Actions #27

Updated by Alexandru Semenenco over 7 years ago

Hi, it's six years ago opened, it is complicated to do this or nobody from developers is interested?

Actions #28

Updated by Kush Suryavanshi over 7 years ago

+1

Actions #29

Updated by Kush Suryavanshi over 7 years ago

For what it's worth, if anyone needs, the following plugin is compatible with Redmine 3.3
https://github.com/seyedmmousavi/redmine_user_specific_theme

Actions #30

Updated by Alexandru Semenenco over 7 years ago

Kush Suryavanshi wrote:

For what it's worth, if anyone needs, the following plugin is compatible with Redmine 3.3
https://github.com/seyedmmousavi/redmine_user_specific_theme

Thanks, work very well.

Actions #31

Updated by Kush Suryavanshi over 7 years ago

Welcome :). Credit goes to the Author. Would be nice if this becomes part of standard Redmine Installation.

Actions #32

Updated by Pierre de LESPINAY almost 7 years ago

+1

Actions #33

Updated by Jihyeon Gim almost 4 years ago

+1

Actions #34

Updated by Go MAEDA almost 4 years ago

Actions #35

Updated by Cyrion Beleriand over 3 years ago

+4 ! (me and my coworkers)

Actions

Also available in: Atom PDF