Project

General

Profile

Actions

Defect #5378

closed

Modified column in Issues view does not obey date format set in Administration > Settings > Display

Added by mathew murphy almost 14 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Normal
Category:
UI
Target version:
-
Start date:
2010-04-23
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

In Administration > Settings > Display I have date format set to 23 Apr 2010, and time format set to "Based on user's language".

However, when I go to a project and select the Issues tab, the Modified column shows (e.g.) 04/19/2010 04:35 pm


Files

i18n.zip (515 Bytes) i18n.zip Alain Alain091, 2010-04-30 12:08
i18n.patch (1.11 KB) i18n.patch unzipped version of Alain's patch Felix Schäfer, 2010-04-30 14:33
always-obey-date-format.diff (1008 Bytes) always-obey-date-format.diff Ebrahim Mohammadi, 2010-12-11 10:56
always-obey-date-format.diff (1012 Bytes) always-obey-date-format.diff Ebrahim Mohammadi, 2010-12-11 11:10

Related issues

Has duplicate Redmine - Defect #7639: Some date fields do not have requested format.Closed2011-02-17

Actions
Actions #1

Updated by mathew murphy almost 14 years ago

Update: If I mandate a time format rather than allowing that to be chosen based on the user's language, then the date format is reflected in the view.

So the bug appears to be that a system-wide date format is only used when the time format is specified system-wide as well.

Actions #2

Updated by Alain Alain091 almost 14 years ago

As I'm volunteer to contribute to Redmine project and I begin with corrections on UI bugs.

Find attached a patch to correct this bug

Actions #3

Updated by Alain Alain091 almost 14 years ago

  • Status changed from New to Resolved

My patch resolve the bug

Actions #4

Updated by Felix Schäfer almost 14 years ago

Hello Alain,
I seem to remember that this was somewhat intended behavior, I can't fathom why though, so don't take my word for it.
Regarding patch submissions: please post the plain patch file so that we can read it online, posting it zipped only induces an extra step (have to download-unzip-open to view it as opposed to viewing it online here in redmine). Lastly, the resolved status is for when the patch is applied to trunk, closed for when the patch is in stable.
Thanks for patch (haven't reviewed it though).

Actions #5

Updated by Alain Alain091 almost 14 years ago

that was my first patch and the situation will improve for the next one

Actions #6

Updated by Ebrahim Mohammadi about 13 years ago

This bug hit me, and I fixed it with the attached patch. The patch is against svn trunk r4485. It makes Redmine follow user-selected date format, even if time format is not set in settings.

Eric Davis, may you assign this issue to someone appropriate to revise and merge one of the patches please? (I assigned it to you to prevent issue from being forgotten.)

Actions #7

Updated by Ebrahim Mohammadi about 13 years ago

Previous patch had indentation issues. It is fixed in this new patch.

Actions #8

Updated by Ebrahim Mohammadi almost 13 years ago

  • Assignee changed from Eric Davis to Jean-Philippe Lang

I think this is fixed in r4894. May you verify?
#7639 seems like a duplicate of this issue.

Actions #9

Updated by Mischa The Evil over 12 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

r4894 fixed it indeed. It was included in Redmine 1.2.0 for #7639.

Actions

Also available in: Atom PDF