Project

General

Profile

Actions

Feature #5655

closed

Allow related issues to be started/due on the same date.

Added by Dan Olsen over 13 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
2010-06-08
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

When I have issue A and issue B, and I assign issue B to follow issue A I want to still be able to schedule the start date for both A and B on the same day.

Currently if I schedule issue A and issue B to start on the same day, than I say issue B follows issue A, issue B's start date is changed to the next day after issue A's due date. Issue A may only take an hour which means issue A and issue B could technically start on the same day.

Instead of moving the B date out a day after the due date of A, set the start date of B to the due date of A and then let me change the start date of B if it needs to be the next day.


Files

seq_issues_start_end_same_day.patch (534 Bytes) seq_issues_start_end_same_day.patch Patch of the fix in comment 1 against r3940 Brian DeVries, 2010-08-17 10:23

Related issues

Has duplicate Redmine - Feature #6127: Preceeded by / followed by - Same dayClosed2010-08-13

Actions
Is duplicate of Redmine - Patch #3195: issue's start date could be the latest due date of predecessorsNew2009-04-17

Actions
Actions #1

Updated by Christopher Lörken over 13 years ago

I've encountered the same issue.

I have fixed this for me like this:
In version 0.9.4 open your app/models/issue_relation.rb file and go to line 79.

Replace

  def successor_soonest_start
    return nil unless (TYPE_PRECEDES == self.relation_type) && (issue_from.start_date || issue_from.due_date)
    (issue_from.due_date || issue_from.start_date) + 1 + delay
  end

with

  def successor_soonest_start
    return nil unless (TYPE_PRECEDES == self.relation_type) && (issue_from.start_date || issue_from.due_date)
    (issue_from.due_date || issue_from.start_date) + delay
  end

in other words: remove the "+ 1" from line 79.
Restart your web server and you can choose the same start and enddates for following tasks.

Actions #2

Updated by Brian DeVries over 13 years ago

As a side note, at least in r3940, this is now on line 94. I've included a patch with this change.

As a question, what would be the general requirements for this feature to be included in Redmine proper? Depending on the complexity, I figure this might be a good introduction to Redmine hacking for me.

Actions #3

Updated by red guv over 13 years ago

Great thanks, Is this being placed into the trunk?

I have noticed that the fix works but gantt charts sort by issue id when tasks are on the start on the same day.
The sort should take into account precedes and follows relationships.

I see the following issue but no action on it.
http://www.redmine.org/issues/3436

It seems logical to include the precedes and follows in the sorting criteria for a gantt chart by default.

Actions #4

Updated by Gabriel Mazetto over 13 years ago

There is a patch to this issue, why it's not merged in the trunk yet?

Actions #5

Updated by Siebe Joris Jochems about 10 years ago

I have the same problem. I use the gantt chart a lot and I love the arrows between issues. When working with small issues (2 hours) a lot of those will start/end on the same day.

Another workaround for this issue is to specify a delay of -1 days when linking the issues.

Actions #6

Updated by Sebastian C over 5 years ago

8 years later, is there any update on this?
Using a delay of -1 certainly works but it's incredibly confusing to anyone who doesn't know why it was necessary to do so.

Actions #7

Updated by Marius BĂLTEANU over 5 years ago

Sebastian C wrote:

8 years later, is there any update on this?
Using a delay of -1 certainly works but it's incredibly confusing to anyone who doesn't know why it was necessary to do so.

There were some discussions about this on #3195. I'll close this issue as duplicated.

Actions #8

Updated by Marius BĂLTEANU over 5 years ago

  • Is duplicate of Patch #3195: issue's start date could be the latest due date of predecessors added
Actions #9

Updated by Marius BĂLTEANU over 5 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate
Actions

Also available in: Atom PDF