Project

General

Profile

Actions

Defect #27407

closed

Default assignee in issue categories doesn't work for groups

Added by Alex Stanev over 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Project settings
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Invalid
Affected version:

Description

In project settings->issue categories we can select certain user to be assigned by default for every category. Choosing group instead of user is accepted here, but the group then doesn't get assigned when this category is selected.
We have enabled "Allow issue assignment to groups".


Files

category.png (33.6 KB) category.png Marius BĂLTEANU, 2018-04-30 12:45
new_issue.png (81.4 KB) new_issue.png Marius BĂLTEANU, 2018-04-30 12:46
issue.png (78 KB) issue.png Marius BĂLTEANU, 2018-04-30 12:46

Related issues

Related to Redmine - Feature #28507: Accept groups in project's default assigneeClosedGo MAEDA

Actions
Actions #1

Updated by Toshi MARUYAMA about 6 years ago

  • Status changed from New to Confirmed
Actions #2

Updated by Go MAEDA almost 6 years ago

  • Related to Feature #28507: Accept groups in project's default assignee added
Actions #3

Updated by Marius BĂLTEANU almost 6 years ago

I've tested this defect on the current trunk (r17320) and 3.4.3 I cannot reproduce it, please see the below steps:

  • Enabled 'Allow issue assignment to groups'
  • Added group "B Team" to a project with a role that has the permission 'Issues can be assigned to this role'.
  • In the 'Issue categories' tab, I've selected 'B Team' as assignee for a category (Recipes as for example).
  • Open new issue
  • Fill in anything as subject
  • Select Recipes as category
  • Create
  • The "B Team" is set as assignee
Actions #4

Updated by Go MAEDA almost 6 years ago

  • Status changed from Needs feedback to Closed
  • Resolution set to Invalid

I confirmed that we can assign a group to categories in Redmine 3.4 and the trunk.

Actions #5

Updated by Alex Stanev almost 6 years ago

I can also confirm it works in 3.4.5 now. Took a quick look over changelogs between 3.4.3 and 3.4.5, but couldn't identify any commits, that would change/fix the behavior. So I attribute this on some wrong configuration from my side.
Thanks to all who looked at it.

Actions

Also available in: Atom PDF