Project

General

Profile

Actions

Patch #36493

closed

Update Polish translation

Added by Robert Korulczyk about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Translations
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Follow up for #33361.

Also, I would appreciate it if you don't change order of translations. In #33361 I intentionally restored order from en.yml, and while it makes this initial diff quite big, it also simplifies translation process, since I can compare translations with English strings side by side (example).


Files

pl.yml (71.8 KB) pl.yml Robert Korulczyk, 2022-01-22 16:47
pl.patch (129 KB) pl.patch Robert Korulczyk, 2022-01-22 16:47
pl.yml (72.1 KB) pl.yml Updated for r21395 Robert Korulczyk, 2022-02-12 23:44
pl.patch (130 KB) pl.patch Updated for r21395 Robert Korulczyk, 2022-02-12 23:44
pl-step1.patch (116 KB) pl-step1.patch Robert Korulczyk, 2022-02-20 12:44
pl-step1.yml (72.1 KB) pl-step1.yml Robert Korulczyk, 2022-02-20 12:44
pl-step2.yml (72.1 KB) pl-step2.yml Robert Korulczyk, 2022-02-20 12:44
pl-step2.patch (29.9 KB) pl-step2.patch Robert Korulczyk, 2022-02-20 12:44
pl.patch (451 Bytes) pl.patch Robert Korulczyk, 2022-10-21 17:15
Actions #1

Updated by Robert Korulczyk about 2 years ago

Updated translations after r21395.

Actions #2

Updated by Go MAEDA about 2 years ago

Robert Korulczyk wrote:

Also, I would appreciate it if you don't change order of translations.

Can you split the patch into two patches? The first patch just changes the order of labels and the second patch updates translations. This makes it easier to track changes in the repository.

Actions #3

Updated by Robert Korulczyk about 2 years ago

Go MAEDA wrote:

Can you split the patch into two patches? The first patch just changes the order of labels and the second patch updates translations. This makes it easier to track changes in the repository.

Done.

Actions #4

Updated by Go MAEDA about 2 years ago

Thank you for posting the new patches but I found some reordering also in pl-step2.patch. I will try to update the patches.

Actions #5

Updated by Robert Korulczyk about 2 years ago

Go MAEDA wrote:

Thank you for posting the new patches but I found some reordering also in pl-step2.patch. I will try to update the patches.

These are new untranslated phrases moved to correct place. If you revert reordering, they will be a problem for future translations, since order of phrases will not match original from en.yml.

I based step1 on original patch from #33361 with new phrases added since then (which are added at the end). If such reordering is a problem, then maybe rake locales:update would be able to respect order from en.yml?

Actions #6

Updated by Go MAEDA almost 2 years ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA

Committed the translations. Thank you for your contribution.

Actions #7

Updated by Marcin Szewczyk over 1 year ago

There is a serious mistake in the translation - uppercase boolean values are inverted!

  general_text_No: 'Tak'
  general_text_Yes: 'Nie'
  general_text_no: 'nie'
  general_text_yes: 'tak'

Should be:

  general_text_No: 'Nie'
  general_text_Yes: 'Tak'
  general_text_no: 'nie'
  general_text_yes: 'tak'

Problem introduced in r21449.

Actions #8

Updated by Robert Korulczyk over 1 year ago

Marcin Szewczyk wrote:

There is a serious mistake in the translation - uppercase boolean values are inverted!

[...]

Should be:
[...]

Problem introduced in r21449.

Sorry about that. I'm attaching a patch to fix this regression.

Actions #9

Updated by Go MAEDA over 1 year ago

  • Status changed from Reopened to Closed

Marcin Szewczyk wrote:

There is a serious mistake in the translation - uppercase boolean values are inverted!

[...]

Should be:
[...]

Problem introduced in r21449.

I have opened a new issue #37812 for this. Thank you for reporting.

Actions

Also available in: Atom PDF