Project

General

Profile

Actions

Feature #6217

closed

When creating a subtask, pre-fill fields Target version, Category & Start- and Due date based on parent values

Added by Martin S over 13 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
2010-08-25
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

When adding a subtask it takes a lot of time to fill the fields
  1. Target version,
  2. Category,
  3. Start date and
  4. Due date

again and again with the same (namely the parent's) values.
I think it is safe to assume, a subtask at least 'inherits' named fields from its parent.

Please add that when adding a new subtask to Redmine, each of said fields is pre-filled with the parent's values.


Related issues

Related to Redmine - Feature #6117: subtasks default to parent issue target versionNew2010-08-12

Actions
Related to Redmine - Feature #13585: Make sub-task inherit the properties of parentNew

Actions
Is duplicate of Redmine - Feature #13810: Copy Fields From Parent Ticket When Adding a SubtaskClosed

Actions
Actions #1

Updated by Cassiano Monteiro almost 13 years ago

+1!

Not sure about the fields "Category", "Start Date" and "End Date", as they may be different from the parent task. But for sure the field "Version" should be inherited, as it´s important to have the same version so the Gantt is displayed correctly.

Actions #2

Updated by Scott Cunningham almost 13 years ago

+1 to inheriting the version.

Actions #3

Updated by Mischa The Evil over 12 years ago

  • Subject changed from when creating a subtask, pre-fill fields Target Version, Category, Start and End Date to When creating a subtask, pre-fill fields Target version, Category & Start- and Due date
Actions #4

Updated by Mischa The Evil over 12 years ago

  • Subject changed from When creating a subtask, pre-fill fields Target version, Category & Start- and Due date to When creating a subtask, pre-fill fields Target version, Category & Start- and Due date based on parent values
Actions #5

Updated by Mathias Kluba over 11 years ago

+1

Actions #6

Updated by Dipan Mehta almost 11 years ago

+1. This is useful. Also, if we combine this with #13561 - it would be very useful and neat.

For example, when you go by New issue you fill up the complete blank form. Where as when you go by 'Add sub-task' all fields come pre-filled.

However, this is not an ultimate solution. Nothing helps when sub-tasks has old information where as parent task is updated. See #13585 for more details.

Actions #7

Updated by Ketki Vahalia about 10 years ago

+1
This is very useful. Every sprint we define the high level deliverable as a task, and then add the detailed subtasks assigned to individual engineers. Having this functionality will make subtask creation much more efficient for us.

Actions #8

Updated by john paul about 10 years ago

+1
This is very useful. Every subtask it takes a lot of time to fill the fields

Fields:

Category
Target version
Customer
Sprint
Milestone
Features
External Ref

when adding a new subtask to Redmine, each of said fields is pre-filled with the parent's task values.

Actions #9

Updated by binnybintoo binnybintoo about 10 years ago

+1
This is very very useful for us, when adding a new subtask to Redmine, each of said fields is pre-filled with the parent's task values.

Actions #10

Updated by Tobias Maier over 9 years ago

+1
Inheritance of the target version is a mandatory feature if You want to manage a project. Otherwise You need a check tool that checks if there are accidentally subtasks that have a different target version than the parent (that is dangerous!).

I recommend that the project settings allow to configure each tracker field if it will be inherited from the parent (if there is a parent).

However, inheritance should only be a default proposal. Of course there are use cases where it makes sense to have different target versions, e.g.:
consider three target versions:

|----target version intermediate----♢0
|----target version release 1---------------------♢1
|----target version release 2----------------------------------♢2

Now consider tasks that are bound to target versions:

Legal

|----task-----------------------------------------♢1
  +----sub task A-------------------♢0
  +----sub task B---------------------------------♢1

Illegal

|----task-----------------------------------------♢1
  +----sub task A-------------------♢0
  +----sub task B----------------------------------------------♢2

Actions #11

Updated by Edosoft Factory over 9 years ago

You should checkout Subtasks Inherited Fields Plugin at https://github.com/edosoft/redmine-inherit-fields-plugin

Actions #12

Updated by Go MAEDA over 5 years ago

  • Is duplicate of Feature #13810: Copy Fields From Parent Ticket When Adding a Subtask added
Actions #13

Updated by Go MAEDA over 5 years ago

  • Status changed from New to Closed

The same feature request with #13810.

Actions

Also available in: Atom PDF