Project

General

Profile

Actions

Defect #6609

open

% Done for Parent Tasks [2]

Added by Ewan Makepeace about 13 years ago. Updated about 2 years ago.

Status:
Reopened
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
Start date:
2010-10-08
Due date:
% Done:

0%

Estimated time:
Resolution:
Affected version:

Description

If I have parent tasks and sub tasks and I use manual (per issue) % done values, then the parent gets the average of the values of the subtasks.
However if I use the option to set % done from status updates then instead of inheriting its % done from the subtasks it takes it from the status attached on the parent task.

Example:

In this case 3 of 4 subtasks are finished and the 4th is in progress, yet the parent task remains at 10% because its status is just 'Developing' (which means not much for a container task).

I actually have two separate requests here:

  1. I think that parent tasks should inherit their done% from the sub tasks in both modes (note that when using per-issue Done% values I do not get the option to pick a value for the parent, it is always computed, so why not for the by-status version too?)
  2. Rather than average the Done of the child tasks I would prefer to weight them by the estimated time of each subtask, so if I have 2 x 8 hr tasks finished and one 4 hour task not started the parent would be at 80 and not 66%.

Files

parent.jpg (45.4 KB) parent.jpg Ewan Makepeace, 2010-10-08 09:36
rm6609-with_done_per_status.png (13.3 KB) rm6609-with_done_per_status.png Mischa The Evil, 2014-01-10 05:57
rm6609-with_done_per_field.png (13.3 KB) rm6609-with_done_per_field.png Mischa The Evil, 2014-01-10 05:57
rm6609-issue_statuses_config.png (4.16 KB) rm6609-issue_statuses_config.png Mischa The Evil, 2014-01-10 05:57

Related issues

Related to Redmine - Feature #22284: Issues statuses: Option to force removal of existing percentage doneNew

Actions
Has duplicate Redmine - Feature #18184: Calculate parent task done ratio based on subtask status.Closed

Actions
Has duplicate Redmine - Defect #13116: When setting Redmine to update the done % by status parent tasks should have the status update according to the done % of the child tasks and not the status. This is the default behavior when you just update by issue.Closed

Actions
Has duplicate Redmine - Feature #15692: calculation of % done with subticketsClosed

Actions
Has duplicate Redmine - Feature #23529: Calculate parent Issue's done ratio from subtasks in case of 'Use the issue status'Closed

Actions
Actions #1

Updated by Daniel Felix almost 11 years ago

  • Status changed from New to Needs feedback

Any news on this? I'm not able to reproduce this.

Is this one fixed already?

Actions #2

Updated by Jan Niggemann (redmine.org team member) almost 10 years ago

  • Status changed from Needs feedback to Resolved
  • Resolution set to No feedback
Actions #3

Updated by Toshi MARUYAMA almost 10 years ago

  • Status changed from Resolved to Closed
Actions #4

Updated by Ewan Makepeace almost 10 years ago

Does that mean it was implemented? Which version?

Actions #5

Updated by Mischa The Evil almost 10 years ago

The behavior given by Ewan in the description is still present on source:/trunk@12577.

The implementation of the done ratio [computed] by issue status option [further referred to as 'the option'] predates the subtasking feature and its behavior has not been changed by the subtasking implementation. Such a change hasn't been discussed as part of subtasking implementation either IIRC.
Considering the scope of the option (and the fact that subtasking isn't computing issue statuses) there can be given arguments against changing the current behavior. One for example is that it would break the pattern of computing the done ratio of the issue based on its status, which is after all the main purpose of the option.

I think this definitely needs some more discussion. Especially from users who are using the option actively in production workflows.

To clarify the issue I'll attach some more screenshots:

with done ratio by issue field with done ratio by issue status issue statuses config
rm6609-with_done_per_field.png rm6609-with_done_per_status.png rm6609-issue_statuses_config.png
Refs:
Actions #6

Updated by Ewan Makepeace almost 10 years ago

Michael Vorobiev: We ended up writing our own patch to fix this annoyance as part of some other improvements, but I must say it seems to negatively impact performance at times. Would be very interested in other peoples feedback.

Actions #7

Updated by Go MAEDA almost 9 years ago

  • Has duplicate Feature #18184: Calculate parent task done ratio based on subtask status. added
Actions #8

Updated by Go MAEDA almost 9 years ago

  • Has duplicate Defect #13116: When setting Redmine to update the done % by status parent tasks should have the status update according to the done % of the child tasks and not the status. This is the default behavior when you just update by issue. added
Actions #9

Updated by Go MAEDA almost 9 years ago

  • Has duplicate Feature #15692: calculation of % done with subtickets added
Actions #10

Updated by Toshi MARUYAMA over 8 years ago

  • Description updated (diff)
Actions #11

Updated by Toshi MARUYAMA over 7 years ago

  • Related to Feature #22284: Issues statuses: Option to force removal of existing percentage done added
Actions #12

Updated by Go MAEDA over 7 years ago

  • Has duplicate Feature #23529: Calculate parent Issue's done ratio from subtasks in case of 'Use the issue status' added
Actions #13

Updated by Go MAEDA over 7 years ago

  • Target version set to Candidate for next major release
Actions #14

Updated by Uuganbayar Battulga over 5 years ago

This is a very important issue. It's not included in version 3.4.4. When will this issue be included in the new releases?

Actions #15

Updated by Manzumul Haque about 5 years ago

I am also facing this issue in version 3.4.6. Waiting for the fix :)

Actions #16

Updated by Elymar Silva over 4 years ago

Looks like the calculation only works if you set the "Calculate the issue done ratio with" option to "Use the issue field" and not to "Use the issue status"

Actions #17

Updated by Go MAEDA over 4 years ago

  • Target version changed from Candidate for next major release to Unplanned backlogs
Actions #18

Updated by Raphael França almost 3 years ago

As alternative for 3.4.X i'm using http://redmine-search.com/redmine-issue-done-ratio-plugin, as it let me use "Use the issue field" and still change Done Ratio based on Issue Status.

Actions #19

Updated by Cristian Bazzucco about 2 years ago

I'm on 4.2.3.stable and the parent percentage calculation works only with "Calculate the issue done ratio with" option to "Use the issue field".
Any feedback to fix it? thx

Actions

Also available in: Atom PDF