Project

General

Profile

Actions

Feature #1244

open

Version dependency

Added by Kenneth Hoxworth almost 16 years ago. Updated almost 11 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
2008-05-15
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

This may be similar to #279.

I'm interested in dependencies between versions, so I could have a version 1.0 target with a bunch of subversions below it, such as 0.1, 0.2, 1.0RC1, etc. Issues in the subversions would automatically be pushed to the parent version, so I can always see how much progress has been made for a major release.

This one issue is what would make me jump from Trac to Redmine.


Files

version-dependency.patch (18 KB) version-dependency.patch Kenneth Hoxworth, 2008-09-23 16:20
Actions #1

Updated by Adam Knight almost 16 years ago

+99.

Actions #2

Updated by Kenneth Hoxworth over 15 years ago

Allright, I never received feedback on this, and my company has begun investigating new tracking tools, so I figured this would be a useful feature. I've integrated 1-level version inheritance across the version creation/edit function, the roadmap, and the show version view. I'm sure I missed something, but so far this meets exactly what we need.

We can now have minor versions all be part of a major version, and can show how much progress has been made on a major version even if there are no issues directly attached to it.

The patch is against revision [1900].

Actions #3

Updated by Kenneth Hoxworth over 15 years ago

Mark that r1900. Still used to doing Trac links.

Actions #4

Updated by Mischa The Evil over 15 years ago

Hi, I just noticed this issue/patch for the first time and tested it against a clean r1900. It works flawlessly.

I personally think this is great patch which extends versioning in Redmine in a nice way. Though like you state some refinements are missing. For example:
  • it would be good to show dependencies in versions-settings view
  • it would be good to show dependencies in versions in drop-downs either
  • tests should be modified to pass I guess

Sad that I use patch #1671 which conflicts heavily with this patch (thus preventing me from using the patch) otherwise I'd apply it immediately...

:thumbsup:

Actions #5

Updated by Kenneth Hoxworth over 15 years ago

I agree - the issues you brought up should be integrated (especially the testing - I couldn't get testing to work for some reason on my local system).

I'll take a look at patch #1671 and see what I can do to possibly make it work together.

Actions #6

Updated by Dipan Mehta almost 11 years ago

+1. This is really a very important feature.

Actions #7

Updated by Daniel Felix almost 11 years ago

Well I would agree that this could be helpful. But there is another approach in the tracker regarding hierarchical versions/milestones.
Maybe this could solve this problem too. Maybe both ideas could be combined and enter the core as one solution?

Actions

Also available in: Atom PDF