Project

General

Profile

Actions

Feature #12032

closed

Collapsible Sidebar

Added by Brandon Liles over 10 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
UI
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

We frequently have meetings in our conference room where we refer to Redmine for information about projects and issues for our organization. We have added a very small amount of JavaScript and CSS to Redmine to allow us to collapse the sidebar so that we have more screen space when viewing found it very useful to be able to collapse the sidebar so that we have more horizontal space on the screen. The is especially useful since we generally increase the font size in the browser.


Files

collapsible-sidebar.diff (1 KB) collapsible-sidebar.diff Brandon Liles, 2012-11-12 19:10

Related issues

Related to Redmine - Feature #10525: A new button to hide/show the sidebarClosed

Actions
Has duplicate Redmine - Feature #12877: optimize ticket / issue view (template / theme)Closed

Actions
Is duplicate of Redmine - Patch #21808: Make the Sidebar collapsible, statefulNeeds feedback

Actions
Actions #1

Updated by Terence Mill over 10 years ago

Please upload the patches.

+ for the feature.

Actions #2

Updated by Toshi MARUYAMA over 10 years ago

  • Category set to UI
Actions #3

Updated by ana gonzalez over 10 years ago

  • Assignee set to Jonas De Meulenaere
  • % Done changed from 0 to 100

Brandon Liles wrote:

We frequently have meetings in our conference room where we refer to Redmine for information about projects and issues for our organization. We have added a very small amount of JavaScript and CSS to Redmine to allow us to collapse the sidebar so that we have more screen space when viewing found it very useful to be able to collapse the sidebar so that we have more horizontal space on the screen. The is especially useful since we generally increase the font size in the browser.

Actions #4

Updated by Toshi MARUYAMA over 10 years ago

  • Assignee deleted (Jonas De Meulenaere)
  • % Done changed from 100 to 0
Actions #5

Updated by Wolfgang Neudorfer over 10 years ago

Terence Mill wrote:

Please upload the patches.

+ for the feature.

I would also love to see the patch.

Actions #6

Updated by Brandon Liles over 10 years ago

Sorry I was slow to provide the patch, diff is attached. The only other thing you need is to apply a little bit of CSS in your theme and have images for the expand/collapse control:

.collapsed #sidebar-content, .collapsed #hide-side-bar, .expanded #show-side-bar, .collapsed #watchers {
   display: none;
}
.expanded #sidebar-content, .expanded #hide-side-bar, .collapsed #show-side-bar, .expanded #watchers {
   display: block;
}
Actions #7

Updated by Terence Mill over 10 years ago

+1 for trunk

Thats slick!

Actions #8

Updated by Jun NAITOH over 10 years ago

+1

Actions #10

Updated by Christian Ziegelt about 10 years ago

Strange - I thought this diff would help me in hiding the sidebar ans saving space.
If I apply the patch (I did it by hand - since I did not find the way to do it automatically) and edit the css file, I will end up with a sidebar which is collapsed from down -> up.

What I thought this was good for is: saving space on the left hand side for tickets.
How to I control that the DIV is collapsed from LEFT to RRIGHT ?

Here is my DIFFed file

<div id="sidebarWrapper" class="expanded">
<p id="hide-side-bar"><a onclick="document.getElementById('sidebarWrapper').className='collapsed';document.getElementById('sidebar').className='collapsed';"><img src="/images/sidebar_collapse.jpeg" /></a></p>
<p id="show-side-bar"><a onclick="document.getElementById('sidebarWrapper').className='expanded';document.getElementById('sidebar').className='expanded';"><img src="/images/sidebar_expand.png" /></a></p>
<div id="sidebar-content" >

<h3><%= l(:label_issue_plural) %></h3>
<%= link_to l(:label_issue_view_all), _project_issues_path(@project, :set_filter => 1) %><br />
<% if @project %>
<%= link_to l(:field_summary), project_issues_report_path(@project) %><br />
<% end %>
<%= call_hook(:view_issues_sidebar_issues_bottom) %>

<% if User.current.allowed_to?(:view_calendar, @project, :global => true) %>
  <%= link_to l(:label_calendar), _project_calendar_path(@project) %><br />
<% end %>
<% if User.current.allowed_to?(:view_gantt, @project, :global => true) %>
  <%= link_to l(:label_gantt), _project_gantt_path(@project) %><br />
<% end %>
<%= call_hook(:view_issues_sidebar_planning_bottom) %>

<%= render_sidebar_queries %>
<%= call_hook(:view_issues_sidebar_queries_bottom) %>

</div>
</div>

Actions #11

Updated by Brandon Liles about 10 years ago

Christian,

Your theme has to use a flexible layout, the content div needs to set width=auto, overflow=auto in the CSS in order for the collapse to work correctly:

This is what the critical section looks like in my hack of the A1 theme:

div#content {
   width: auto;
   overflow: auto;
}

div#main.nosidebar div#content {
   width: auto;
}

#sidebar {
   width: auto;

Actions #12

Updated by Daniel Felix about 10 years ago

  • Tracker changed from Feature to Patch
  • Target version set to 2.4.0

I have detected, that this one is a duplicate of #10525.
Normally, the newer post should be closed as duplicate. But I will change this tracker type to patch, as this contains many hints to complete #10525.

Actions #13

Updated by Ivan Cenov about 10 years ago

There is also a plugin for hiding sidebar: https://github.com/ries-tech/sidebar_hide

Actions #14

Updated by Dipan Mehta about 10 years ago

As I stated in #1294

I am using the above mentioned plugin

Many themes are simply not compatible with the the plug-in. Unfortunately, by digging up you realize this is is neither a plug-in's own issue as such because many themes have their own peculiar problems (and default theme works) on the other hand - most themes works perfectly except this side bar features!

This feature should be core, as it affects UI for all the modules, layouts. Usually, if plugins being maintained by others cann't be controlled but whatever is solved once in Redmine core is mostly likely to be supported for the rest. Hence, I think this should be part of core.

Actions #15

Updated by Jean-Philippe Lang over 9 years ago

  • Target version changed from 2.4.0 to Candidate for next major release

2.4 feature freeze

Actions #16

Updated by Hans Bangkok about 9 years ago

yes this really should be core, so many important 3rd-party plugins have fallen by the wayside

Actions #17

Updated by Jérôme BATAILLE almost 8 years ago

Hi, a plugin was developped inside my company.
Still working with current version.

https://github.com/Smile-SA/redmine_smile_togglesidebar

Actions #18

Updated by Toshi MARUYAMA about 7 years ago

  • Related to Patch #21808: Make the Sidebar collapsible, stateful added
Actions #19

Updated by Edgars Batna almost 4 years ago

+999999999

Actions #20

Updated by Marius BALTEANU over 3 years ago

  • Tracker changed from Patch to Feature
  • Status changed from New to Closed
  • Target version deleted (Candidate for next major release)
  • Resolution set to Duplicate

Closing this in favour of #21808 which has multiple patches and a feedback from Jean-Philippe.

Actions #21

Updated by Marius BALTEANU over 3 years ago

  • Related to deleted (Patch #21808: Make the Sidebar collapsible, stateful)
Actions #22

Updated by Marius BALTEANU over 3 years ago

  • Is duplicate of Patch #21808: Make the Sidebar collapsible, stateful added
Actions

Also available in: Atom PDF